Compress::Zlib: Buffer overflow — GLSA 200508-01

Compress::Zlib is vulnerable to a buffer overflow which could potentially lead to execution of arbitrary code.

Affected Packages

perl-core/Compress-Zlib on all architectures
Affected versions < 1.35
Unaffected versions >= 1.35

Background

The Compress::Zlib is a Perl module which provides an interface to the zlib compression library.

Description

Compress::Zlib 1.34 contains a local vulnerable version of zlib, which may lead to a buffer overflow.

Impact

By creating a specially crafted compressed data stream, attackers can overwrite data structures for applications that use Compress::Zlib, resulting in a Denial of Service and potentially arbitrary code execution.

Workaround

There is no known workaround at this time.

Resolution

All Compress::Zlib users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=perl-core/Compress-Zlib-1.35"

References

Release Date
August 01, 2005

Latest Revision
May 28, 2009: 02

Severity
high

Exploitable
remote

Bugzilla entries