nbSMTP: Format string vulnerability — GLSA 200508-03

nbSMTP is vulnerable to a format string vulnerability which may result in remote execution of arbitrary code.

Affected Packages

mail-mta/nbsmtp on all architectures
Affected versions < 1.00
Unaffected versions >= 1.00

Background

nbSMTP is an SMTP client suitable to run in chroot jails, in embedded systems, laptops and workstations.

Description

Niels Heinen discovered a format string vulnerability.

Impact

An attacker can setup a malicious SMTP server and exploit this vulnerability to execute arbitrary code with the permissions of the user running nbSMTP.

Workaround

There is no known workaround at this time.

Resolution

All nbSMTP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-mta/nbsmtp-1.0"

References

Release Date
August 02, 2005

Latest Revision
August 11, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries