Netpbm: Arbitrary code execution in pstopnm — GLSA 200508-04

The pstopnm utility, part of the Netpbm tools, contains a vulnerability which can potentially result in the execution of arbitrary code.

Affected Packages

media-libs/netpbm on all architectures
Affected versions < 10.28
Unaffected versions >= 10.28, revision >= 10.26.32, revision >= 10.26.33, revision >= 10.26.42, revision >= 10.26.43, revision >= 10.26.44, revision >= 10.26.48, revision >= 10.26.49, revision >= 10.26.59, revision >= 10.26.61

Background

Netpbm is a package of 220 graphics programs and a programming libraries, including pstopnm. pstopnm is a tool which converts PostScript files to PNM image files.

Description

Max Vozeler reported that pstopnm calls the GhostScript interpreter on untrusted PostScript files without specifying the -dSAFER option, to convert a PostScript file into a PBM, PGM, or PNM file.

Impact

An attacker could craft a malicious PostScript file and entice a user to run pstopnm on it, resulting in the execution of arbitrary commands with the permissions of the user running pstopnm.

Workaround

There is no known workaround at this time.

Resolution

All Netpbm users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose media-libs/netpbm

References

Release Date
August 05, 2005

Latest Revision
May 28, 2009: 06

Severity
normal

Exploitable
remote

Bugzilla entries