Xpdf, Kpdf, GPdf: Denial of Service vulnerability — GLSA 200508-08

Xpdf, Kpdf and GPdf may crash as a result of a Denial of Service vulnerability.

Affected Packages

app-text/xpdf on all architectures
Affected versions < 3.00-r10
Unaffected versions >= 3.00-r10
kde-base/kdegraphics on all architectures
Affected versions < 3.3.2-r3
Unaffected versions >= 3.3.2-r3
kde-base/kpdf on all architectures
Affected versions < 3.4.1-r1
Unaffected versions >= 3.4.1-r1
app-text/gpdf on all architectures
Affected versions < 2.10.0-r1
Unaffected versions >= 2.10.0-r1

Background

Xpdf, Kpdf and GPdf are PDF file viewers that run under the X Window System. Kpdf and GPdf both contain Xpdf code. Kpdf is also part of kdegraphics.

Description

Xpdf, Kpdf and GPdf do not handle a broken table of embedded TrueType fonts correctly. After detecting such a table, Xpdf, Kpdf and GPdf attempt to reconstruct the information in it by decoding the PDF file, which causes the generation of a huge temporary file.

Impact

A remote attacker may cause a Denial of Service by creating a specially crafted PDF file, sending it to a CUPS printing system (which uses Xpdf), or by enticing a user to open it in Xpdf, Kpdf, or GPdf.

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.00-r10"

All GPdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r1"

All Kpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/kdegraphics-3.3.2-r3"

All KDE Split Ebuild Kpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=kde-base/kpdf-3.4.1-r1"

References

Release Date
August 16, 2005

Latest Revision
August 16, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries