Adobe Reader is vulnerable to a buffer overflow which could potentially lead to execution of arbitrary code.
|Package||app-text/acroread on all architectures|
|Affected versions||< 18.104.22.168|
|Unaffected versions||>= 22.214.171.124|
Adobe Reader is a utility used to view PDF files.
A buffer overflow has been reported within a core application plug-in, which is part of Adobe Reader.
An attacker may create a specially-crafted PDF file, enticing a user to open it. This could trigger a buffer overflow as the file is being loaded, resulting in the execution of arbitrary code.
There is no known workaround at this time.
All Adobe Reader users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=app-text/acroread-126.96.36.199"
August 19, 2005
August 19, 2005: 01