libpcre: Heap integer overflow — GLSA 200508-17

libpcre is vulnerable to a heap integer overflow, possibly leading to the execution of arbitrary code.

Affected Packages

dev-libs/libpcre on all architectures
Affected versions < 6.3
Unaffected versions >= 6.3

Background

libpcre is a library providing functions for Perl-compatible regular expressions.

Description

libpcre fails to check certain quantifier values in regular expressions for sane values.

Impact

An attacker could possibly exploit this vulnerability to execute arbitrary code by sending specially crafted regular expressions to applications making use of the libpcre library.

Workaround

There is no known workaround at this time.

Resolution

All libpcre users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-6.3"

References

Release Date
August 25, 2005

Latest Revision
August 25, 2005: 01

Severity
high

Exploitable
remote

Bugzilla entries