phpGroupWare: Multiple vulnerabilities — GLSA 200508-20

phpGroupWare is vulnerable to multiple issues ranging from information disclosure to a potential execution of arbitrary code.

Affected Packages

www-apps/phpgroupware on all architectures
Affected versions < 0.9.16.008
Unaffected versions >= 0.9.16.008

Background

phpGroupWare is a multi-user groupware suite written in PHP.

Description

phpGroupWare improperly validates the "mid" parameter retrieved via a forum post. The current version of phpGroupWare also adds several safeguards to prevent XSS issues, and disables the use of a potentially vulnerable XML-RPC library.

Impact

A remote attacker may leverage the XML-RPC vulnerability to execute arbitrary PHP script code. He could also create a specially crafted request that will reveal private posts.

Workaround

There is no known workaround at this time.

Resolution

All phpGroupWare users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/phpgroupware-0.9.16.008"

References

Release Date
August 30, 2005

Latest Revision
August 30, 2005: 01

Severity
high

Exploitable
remote

Bugzilla entries