Apache, mod_ssl: Multiple vulnerabilities — GLSA 200509-12

mod_ssl and Apache are vulnerable to a restriction bypass and a potential local privilege escalation.

Affected Packages

net-www/mod_ssl on all architectures
Affected versions < 2.8.24
Unaffected versions >= 2.8.24
www-servers/apache on all architectures
Affected versions < 2.0.54-r15
Unaffected versions >= 2.0.54-r15, < 2

Background

The Apache HTTP server is one of the most popular web servers on the Internet. mod_ssl provides SSL v2/v3 and TLS v1 support for Apache 1.3 and is also included in Apache 2.

Description

mod_ssl contains a security issue when "SSLVerifyClient optional" is configured in the global virtual host configuration (CAN-2005-2700). Also, Apache's httpd includes a PCRE library, which makes it vulnerable to an integer overflow (CAN-2005-2491).

Impact

Under a specific configuration, mod_ssl does not properly enforce the client-based certificate authentication directive, "SSLVerifyClient require", in a per-location context, which could be potentially used by a remote attacker to bypass some restrictions. By creating a specially crafted ".htaccess" file, a local attacker could possibly exploit Apache's vulnerability, which would result in a local privilege escalation.

Workaround

There is no known workaround at this time.

Resolution

All mod_ssl users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-www/mod_ssl-2.8.24"

All Apache 2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.54-r15"

References

Release Date
September 19, 2005

Latest Revision
December 30, 2007: 03

Severity
normal

Exploitable
remote and local

Bugzilla entries