Zope: File inclusion through RestructuredText — GLSA 200510-20

Zope is vulnerable to a file inclusion vulnerability when exposing RestructuredText functionalities to untrusted users.

Affected Packages

net-zope/zope on all architectures
Affected versions < 2.7.8, = 2.8.0, = 2.8.1
Unaffected versions >= 2.7.8

Background

Zope is an application server that can be used to build content management systems, intranets, portals or other custom applications.

Description

Zope honors file inclusion directives in RestructuredText objects by default.

Impact

An attacker could exploit the vulnerability by sending malicious input that would be interpreted in a RestructuredText Zope object, potentially resulting in the execution of arbitrary Zope code with the rights of the Zope server.

Workaround

There is no known workaround at this time.

Resolution

All Zope users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose net-zope/zope

References

Release Date
October 25, 2005

Latest Revision
May 22, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries