TikiWiki: XSS vulnerability — GLSA 200510-23

TikiWiki is vulnerable to cross-site scripting attacks.

Affected Packages

www-apps/tikiwiki on all architectures
Affected versions < 1.9.1.1
Unaffected versions >= 1.9.1.1

Background

TikiWiki is a web-based groupware and content management system (CMS), using PHP, ADOdb and Smarty.

Description

Due to improper input validation, TikiWiki can be exploited to perform cross-site scripting attacks.

Impact

A remote attacker could exploit this to inject and execute malicious script code or to steal cookie-based authentication credentials, potentially compromising the victim's browser.

Workaround

There is no known workaround at this time.

Resolution

All TikiWiki users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.9.1.1"

Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.

References

Release Date
October 28, 2005

Latest Revision
May 22, 2006: 02

Severity
low

Exploitable
remote

Bugzilla entries