GNUMP3d: Directory traversal and XSS vulnerabilities — GLSA 200511-05

GNUMP3d is vulnerable to directory traversal and cross-site scripting attacks that may result in information disclosure or the compromise of a browser.

Affected Packages

media-sound/gnump3d on all architectures
Affected versions < 2.9_pre7
Unaffected versions >= 2.9_pre7

Background

GNUMP3d is a streaming server for MP3s, OGG vorbis files, movies and other media formats.

Description

Steve Kemp reported about two cross-site scripting attacks that are related to the handling of files (CVE-2005-3424, CVE-2005-3425). Also reported is a directory traversal vulnerability which comes from the attempt to sanitize input paths (CVE-2005-3123).

Impact

A remote attacker could exploit this to disclose sensitive information or inject and execute malicious script code, potentially compromising the victim's browser.

Workaround

There is no known workaround at this time.

Resolution

All GNUMP3d users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-sound/gnump3d-2.9_pre7"

References

Release Date
November 06, 2005

Latest Revision
August 21, 2007: 02

Severity
normal

Exploitable
remote

Bugzilla entries