GTK+ 2, GdkPixbuf: Multiple XPM decoding vulnerabilities — GLSA 200511-14

The GdkPixbuf library, that is also included in GTK+ 2, contains vulnerabilities that could lead to a Denial of Service or the execution of arbitrary code.

Affected Packages

x11-libs/gtk+ on all architectures
Affected versions < 2.8.6-r1
Unaffected versions >= 2.8.6-r1, revision >= 2.6.10-r1, < 2.0
media-libs/gdk-pixbuf on all architectures
Affected versions < 0.22.0-r5
Unaffected versions >= 0.22.0-r5

Background

GTK+ (the GIMP Toolkit) is a toolkit for creating graphical user interfaces. The GdkPixbuf library provides facilities for image handling. It is available as a standalone library and also packaged with GTK+ 2.

Description

iDEFENSE reported a possible heap overflow in the XPM loader (CVE-2005-3186). Upon further inspection, Ludwig Nussel discovered two additional issues in the XPM processing functions : an integer overflow (CVE-2005-2976) that affects only gdk-pixbuf, and an infinite loop (CVE-2005-2975).

Impact

Using a specially crafted XPM image an attacker could cause an affected application to enter an infinite loop or trigger the overflows, potentially allowing the execution of arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All GTK+ 2 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose x11-libs/gtk+

All GdkPixbuf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/gdk-pixbuf-0.22.0-r5"

References

Release Date
November 16, 2005

Latest Revision
November 16, 2005: 01

Severity
normal

Exploitable
remote

Bugzilla entries