Openswan, IPsec-Tools: Vulnerabilities in ISAKMP Protocol implementation — GLSA 200512-04

Openswan and IPsec-Tools suffer from an implementation flaw which may allow a Denial of Service attack.

Affected Packages

net-misc/openswan on all architectures
Affected versions < 2.4.4
Unaffected versions >= 2.4.4
net-firewall/ipsec-tools on all architectures
Affected versions < 0.6.3
Unaffected versions >= 0.6.3, revision >= 0.6.2-r1, revision >= 0.4-r2

Background

Openswan is an implementation of IPsec for Linux. IPsec-Tools is a port of KAME's implementation of the IPsec utilities, including racoon, an Internet Key Exchange daemon. Internet Key Exchange version 1 (IKEv1), a derivate of ISAKMP, is an important part of IPsec. IPsec is widely used to secure exchange of packets at the IP layer and mostly used to implement Virtual Private Networks (VPNs).

Description

The Oulu University Secure Programming Group (OUSPG) discovered that various ISAKMP implementations, including Openswan and racoon (included in the IPsec-Tools package), behave in an anomalous way when they receive and handle ISAKMP Phase 1 packets with invalid or abnormal contents.

Impact

A remote attacker could craft specific packets that would result in a Denial of Service attack, if Openswan and racoon are used in specific, weak configurations.

Workaround

There is no known workaround at this time.

Resolution

All Openswan users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/openswan-2.4.4"

All IPsec-Tools users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose net-firewall/ipsec-tools

References

Release Date
December 12, 2005

Latest Revision
December 14, 2005: 02

Severity
low

Exploitable
remote

Bugzilla entries