Xpdf, GPdf, CUPS, Poppler: Multiple vulnerabilities — GLSA 200512-08

Multiple vulnerabilities have been discovered in Xpdf, GPdf, CUPS and Poppler potentially resulting in the execution of arbitrary code.

Affected Packages

app-text/xpdf on all architectures
Affected versions < 3.01-r2
Unaffected versions >= 3.01-r2
app-text/gpdf on all architectures
Affected versions < 2.10.0-r2
Unaffected versions >= 2.10.0-r2
app-text/poppler on all architectures
Affected versions < 0.4.2-r1
Unaffected versions >= 0.4.2-r1, revision >= 0.3.0-r1
net-print/cups on all architectures
Affected versions < 1.1.23-r3
Unaffected versions >= 1.1.23-r3

Background

Xpdf and GPdf are PDF file viewers that run under the X Window System. Poppler is a PDF rendering library based on Xpdf code. The Common UNIX Printing System (CUPS) is a cross-platform print spooler. It makes use of Xpdf code to handle PDF files.

Description

infamous41md discovered that several Xpdf functions lack sufficient boundary checking, resulting in multiple exploitable buffer overflows.

Impact

An attacker could entice a user to open a specially-crafted PDF file which would trigger an overflow, potentially resulting in execution of arbitrary code with the rights of the user running Xpdf, CUPS, GPdf or Poppler.

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r2"

All GPdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r2"

All Poppler users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose app-text/poppler

All CUPS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-print/cups-1.1.23-r3"

References

Release Date
December 16, 2005

Latest Revision
December 17, 2005: 02

Severity
normal

Exploitable
remote

Bugzilla entries