MyDNS: Denial of Service — GLSA 200601-16

MyDNS contains a vulnerability that may lead to a Denial of Service attack.

Affected Packages

net-dns/mydns on all architectures
Affected versions < 1.1.0
Unaffected versions >= 1.1.0

Background

MyDNS is a DNS server using a MySQL database as a backend. It is designed to allow for fast updates and small resource usage.

Description

MyDNS contains an unspecified flaw that may allow a remote Denial of Service.

Impact

An attacker could cause a Denial of Service by sending malformed DNS queries to the MyDNS server.

Workaround

There is no known workaround at this time.

Resolution

All MyDNS users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dns/mydns-1.1.0"

References

Release Date
January 30, 2006

Latest Revision
January 30, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries