Xpdf, Poppler, GPdf, libextractor, pdftohtml: Heap overflows — GLSA 200601-17

Xpdf, Poppler, GPdf, libextractor and pdftohtml are vulnerable to integer overflows that may be exploited to execute arbitrary code.

Affected Packages

app-text/xpdf on all architectures
Affected versions < 3.01-r5
Unaffected versions >= 3.01-r5
app-text/poppler on all architectures
Affected versions < 0.4.3-r4
Unaffected versions >= 0.4.3-r4
app-text/gpdf on all architectures
Affected versions < 2.10.0-r3
Unaffected versions >= 2.10.0-r3
media-libs/libextractor on all architectures
Affected versions < 0.5.9
Unaffected versions >= 0.5.9
app-text/pdftohtml on all architectures
Affected versions < 0.36-r4
Unaffected versions

Background

Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base. GPdf is a PDF file viewer for the GNOME 2 platform, also based on Xpdf. libextractor is a library which includes Xpdf code to extract arbitrary meta-data from files. pdftohtml is a utility to convert PDF files to HTML or XML formats that makes use of Xpdf code to decode PDF files.

Description

Chris Evans has reported some integer overflows in Xpdf when attempting to calculate buffer sizes for memory allocation, leading to a heap overflow and a potential infinite loop when handling malformed input files.

Impact

By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r5"

All Poppler users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/poppler-0.4.3-r4"

All GPdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r3"

All libextractor users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/libextractor-0.5.9"

All pdftohtml users should migrate to the latest stable version of Poppler.

References

Release Date
January 30, 2006

Latest Revision
January 30, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries