Apache can be exploited for cross-site scripting attacks and is vulnerable to a Denial of Service attack.
|Package||www-servers/apache on all architectures|
|Affected versions||< 2.0.55-r1|
|Unaffected versions||>= 2.0.55-r1, revision >= 2.0.54-r16, = 1.3.34-r2, revision >= 1.3.34-r11, revision >= 1.3.37|
The Apache HTTP server is one of the most popular web servers on the Internet. mod_imap provides support for server-side image maps; mod_ssl provides secure HTTP connections.
Apache's mod_imap fails to properly sanitize the "Referer" directive of imagemaps in some cases, leaving the HTTP Referer header unescaped. A flaw in mod_ssl can lead to a NULL pointer dereference if the site uses a custom "Error 400" document. These vulnerabilities were reported by Marc Cox and Hartmut Keil, respectively.
There is no known workaround at this time.
All Apache users should upgrade to the latest version, depending on whether they still use the old configuration style (/etc/apache/conf/*.conf) or the new one (/etc/apache2/httpd.conf).
2.0.x users, new style config:
# emerge --sync # emerge --ask --oneshot --verbose ">=www-servers/apache-2.0.55-r1"
2.0.x users, old style config:
# emerge --sync # emerge --ask --oneshot --verbose "=www-servers/apache-2.0.54-r16"
1.x users, new style config:
# emerge --sync # emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r11"
1.x users, old style config:
# emerge --sync # emerge --ask --oneshot --verbose "=www-servers/apache-1.3.34-r2"