Xpdf, Poppler: Heap overflow — GLSA 200602-04

Xpdf and Poppler are vulnerable to a heap overflow that may be exploited to execute arbitrary code.

Affected Packages

app-text/xpdf on all architectures
Affected versions < 3.01-r7
Unaffected versions >= 3.01-r7
app-text/poppler on all architectures
Affected versions < 0.5.0-r4
Unaffected versions >= 0.5.0-r4

Background

Xpdf is a PDF file viewer that runs under the X Window System. Poppler is a PDF rendering library based on the Xpdf 3.0 code base.

Description

Dirk Mueller has reported a vulnerability in Xpdf. It is caused by a missing boundary check in the splash rasterizer engine when handling PDF splash images with overly large dimensions.

Impact

By sending a specially crafted PDF file to a victim, an attacker could cause an overflow, potentially resulting in the execution of arbitrary code with the privileges of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Xpdf users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/xpdf-3.01-r7"

All Poppler users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/poppler-0.5.0-r4"

References

Release Date
February 12, 2006

Latest Revision
February 12, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries