GPdf: heap overflows in included Xpdf code — GLSA 200602-12

GPdf includes vulnerable Xpdf code to handle PDF files, making it vulnerable to the execution of arbitrary code.

Affected Packages

app-text/gpdf on all architectures
Affected versions < 2.10.0-r4
Unaffected versions >= 2.10.0-r4

Background

GPdf is a Gnome PDF viewer.

Description

Dirk Mueller found a heap overflow vulnerability in the XPdf codebase when handling splash images that exceed size of the associated bitmap.

Impact

An attacker could entice a user to open a specially crafted PDF file with GPdf, potentially resulting in the execution of arbitrary code with the rights of the user running the affected application.

Workaround

There is no known workaround at this time.

Resolution

All GPdf users should upgrade to the latest version.

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/gpdf-2.10.0-r4"

References

Release Date
February 21, 2006

Latest Revision
February 21, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries