WordPress: SQL injection vulnerability — GLSA 200603-01

WordPress is vulnerable to an SQL injection vulnerability.

Affected Packages

www-apps/wordpress on all architectures
Affected versions <= 1.5.2
Unaffected versions >= 2.0.1

Background

WordPress is a PHP and MySQL based content management and publishing system.

Description

Patrik Karlsson reported that WordPress 1.5.2 makes use of an insufficiently filtered User Agent string in SQL queries related to comments posting. This vulnerability was already fixed in the 2.0-series of WordPress.

Impact

An attacker could send a comment with a malicious User Agent parameter, resulting in SQL injection and potentially in the subversion of the WordPress database. This vulnerability wouldn't affect WordPress sites which do not allow comments or which require that comments go through a moderator.

Workaround

Disable or moderate comments on your WordPress blogs.

Resolution

All WordPress users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/wordpress-2.0.1"

References

Release Date
March 04, 2006

Latest Revision
March 04, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries