PEAR-Auth: Potential authentication bypass — GLSA 200603-13

PEAR-Auth did not correctly verify data passed to the DB and LDAP containers, thus allowing to inject false credentials to bypass the authentication.

Affected Packages

dev-php/PEAR-Auth on all architectures
Affected versions < 1.2.4
Unaffected versions >= 1.2.4

Background

PEAR-Auth is a PEAR package that provides methods to create a PHP based authentication system.

Description

Matt Van Gundy discovered that PEAR-Auth did not correctly validate data passed to the DB and LDAP containers.

Impact

A remote attacker could possibly exploit this vulnerability to bypass the authentication mechanism by injecting specially crafted input to the underlying storage containers.

Workaround

There is no known workaround at this time.

Resolution

All PEAR-Auth users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-php/PEAR-Auth-1.2.4"

References

Release Date
March 17, 2006

Latest Revision
March 17, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries