Dia: Arbitrary code execution through XFig import — GLSA 200604-14

Buffer overflows in Dia's XFig import could allow remote attackers to execute arbitrary code.

Affected Packages

app-office/dia on all architectures
Affected versions < 0.94-r5
Unaffected versions >= 0.94-r5

Background

Dia is a GTK+ based diagram creation program.

Description

infamous41md discovered multiple buffer overflows in Dia's XFig file import plugin.

Impact

By enticing a user to import a specially crafted XFig file into Dia, an attacker could exploit this issue to execute arbitrary code with the rights of the user running Dia.

Workaround

There is no known workaround at this time.

Resolution

All Dia users should upgrade to the latest available version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-office/dia-0.94-r5"

References

Release Date
April 23, 2006

Latest Revision
April 23, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries