Mozilla Firefox: Potential remote code execution — GLSA 200605-06

The Mozilla Firefox 1.5 line is vulnerable to a buffer overflow in the JavaScript extension which may in theory lead to remote execution of arbitrary code.

Affected Packages

www-client/mozilla-firefox on all architectures
Affected versions < 1.5.0.3
Unaffected versions >= 1.5.0.3, < 1.5
www-client/mozilla-firefox-bin on all architectures
Affected versions < 1.5.0.3
Unaffected versions >= 1.5.0.3, < 1.5

Background

Mozilla Firefox is the next-generation web browser from the Mozilla project.

Description

Martijn Wargers and Nick Mott discovered a vulnerability when rendering malformed JavaScript content. The Mozilla Firefox 1.0 line is not affected.

Impact

If JavaScript is enabled, by tricking a user into visiting a malicious web page which would send a specially crafted HTML script that contains references to deleted objects with the "designMode" property enabled, an attacker can crash the web browser and in theory manage to execute arbitrary code with the rights of the user running the browser.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox 1.5 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.5.0.3"

All Mozilla Firefox 1.5 binary users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-1.5.0.3"

References

Release Date
May 06, 2006

Latest Revision
May 06, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries