PHP: Multiple vulnerabilities — GLSA 200605-08

PHP is affected by multiple issues, including a buffer overflow in wordwrap() which may lead to execution of arbitrary code.

Affected Packages

dev-lang/php on the arm hppa ppc s390 sh sparc x86 x86-fbsd architecture
Affected versions < 5.1.4
Unaffected versions >= 5.1.4, revision >= 4.4.2-r2, revision >= 4.4.3-r1, revision >= 4.4.4-r4, revision >= 4.4.6, >= 4.4.7
dev-lang/php on the alpha amd64 ia64 ppc64 architecture
Affected versions < 5.1.4-r4
Unaffected versions >= 5.1.4-r4, revision >= 4.4.2-r6, revision >= 4.4.3-r1, revision >= 4.4.4-r4, revision >= 4.4.6, >= 4.4.7

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Description

Several vulnerabilities were discovered on PHP4 and PHP5 by Infigo, Tonu Samuel and Maksymilian Arciemowicz. These included a buffer overflow in the wordwrap() function, restriction bypasses in the copy() and tempname() functions, a cross-site scripting issue in the phpinfo() function, a potential crash in the substr_compare() function and a memory leak in the non-binary-safe html_entity_decode() function.

Impact

Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.

Workaround

There is no known workaround at this point.

Resolution

All PHP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose dev-lang/php

References

Release Date
May 08, 2006

Latest Revision
May 15, 2007: 09

Severity
high

Exploitable
remote

Bugzilla entries