Quake 3 engine based games: Buffer Overflow — GLSA 200605-12

The Quake 3 engine has a vulnerability that could be exploited to execute arbitrary code.

Affected Packages

games-fps/quake3-bin on all architectures
Affected versions < 1.32c
Unaffected versions >= 1.32c
games-fps/rtcw on all architectures
Affected versions < 1.41b
Unaffected versions >= 1.41b
games-fps/enemy-territory on all architectures
Affected versions < 2.60b
Unaffected versions >= 2.60b

Background

Quake 3 is a multiplayer first person shooter.

Description

landser discovered a vulnerability within the "remapShader" command. Due to a boundary handling error in "remapShader", there is a possibility of a buffer overflow.

Impact

An attacker could set up a malicious game server and entice users to connect to it, potentially resulting in the execution of arbitrary code with the rights of the game user.

Workaround

Do not connect to untrusted game servers.

Resolution

All Quake 3 users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=games-fps/quake3-bin-1.32c"

All RTCW users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=games-fps/rtcw-1.41b"

All Enemy Territory users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=games-fps/enemy-territory-2.60b"

References

Release Date
May 10, 2006

Latest Revision
May 10, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries