Horde Web Application Framework: XSS vulnerability — GLSA 200606-28

The Horde Web Application Framework is vulnerable to a cross-site scripting vulnerability.

Affected Packages

www-apps/horde on all architectures
Affected versions < 3.1.1-r1
Unaffected versions >= 3.1.1-r1

Background

The Horde Web Application Framework is a general-purpose web application framework written in PHP, providing classes for handling preferences, compression, browser detection, connection tracking, MIME, and more.

Description

Michael Marek discovered that the Horde Web Application Framework performs insufficient input sanitizing.

Impact

An attacker could exploit these vulnerabilities to execute arbitrary scripts running in the context of the victim's browser.

Workaround

There is no known workaround at this time.

Resolution

All horde users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-apps/horde-3.1.1-r1"

References

Release Date
June 29, 2006

Latest Revision
June 29, 2006: 01

Severity
low

Exploitable
remote

Bugzilla entries