PostgreSQL: SQL injection — GLSA 200607-04

A flaw in the multibyte character handling allows execution of arbitrary SQL statements.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 8.0.8, < 7.4.13
Unaffected versions >= 8.0.8, = 7.4*

Background

PostgreSQL is an open source object-relational database management system.

Description

PostgreSQL contains a flaw in the string parsing routines that allows certain backslash-escaped characters to be bypassed with some multibyte character encodings. This vulnerability was discovered by Akio Ishida and Yasuo Ohgaki.

Impact

An attacker could execute arbitrary SQL statements on the PostgreSQL server. Be aware that web applications using PostgreSQL as a database back-end might be used to exploit this vulnerability.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version in the respective branch they are using:

 # emerge --sync
 # emerge --ask --oneshot --verbose dev-db/postgresql

Note: While a fix exists for the 7.3 branch it doesn't currently work on Gentoo. All 7.3.x users of PostgreSQL should consider updating their installations to the 7.4 (or higher) branch as soon as possible!

References

Release Date
July 09, 2006

Latest Revision
June 26, 2007: 03

Severity
normal

Exploitable
remote

Bugzilla entries