GIMP: Buffer overflow — GLSA 200607-08

GIMP is prone to a buffer overflow which may lead to the execution of arbitrary code when loading specially crafted XCF files.

Affected Packages

media-gfx/gimp on all architectures
Affected versions < 2.2.12
Unaffected versions >= 2.2.12

Background

GIMP is the GNU Image Manipulation Program. XCF is the native image file format used by GIMP.

Description

Henning Makholm discovered that the "xcf_load_vector()" function is vulnerable to a buffer overflow when loading a XCF file with a large "num_axes" value.

Impact

An attacker could exploit this issue to execute arbitrary code by enticing a user to open a specially crafted XCF file.

Workaround

There is no known workaround at this time.

Resolution

All GIMP users should update to the latest stable version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-gfx/gimp-2.2.12"

References

Release Date
July 23, 2006

Latest Revision
July 24, 2006: 02

Severity
normal

Exploitable
remote

Bugzilla entries