Apache: Off-by-one flaw in mod_rewrite — GLSA 200608-01

A flaw in mod_rewrite could result in a Denial of Service or the execution of arbitrary code.

Affected Packages

www-servers/apache on all architectures
Affected versions < 2.0.58-r2
Unaffected versions revision >= 1.3.34-r14, revision >= 1.3.37, >= 2.0.58-r2

Background

The Apache HTTP server is one of the most popular web servers on the Internet. The Apache module mod_rewrite provides a rule-based engine to rewrite requested URLs on the fly.

Description

An off-by-one flaw has been found in Apache's mod_rewrite module by Mark Dowd of McAfee Avert Labs. This flaw is exploitable depending on the types of rewrite rules being used.

Impact

A remote attacker could exploit the flaw to cause a Denial of Service or execution of arbitrary code. Note that Gentoo Linux is not vulnerable in the default configuration.

Workaround

There is no known workaround at this time.

Resolution

All Apache users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose www-servers/apache

References

Release Date
August 01, 2006

Latest Revision
December 30, 2007: 02

Severity
high

Exploitable
remote

Bugzilla entries