PHP contains a function that, when used, could allow a remote attacker to execute arbitrary code.
|Package||dev-lang/php on all architectures|
|Affected versions||< 5.1.4-r6|
|Unaffected versions||revision >= 4.4.3-r1
revision >= 4.4.4-r4
revision >= 4.4.6
revision >= 4.4.7
revision >= 4.4.8_pre20070816
PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.
The sscanf() PHP function contains an array boundary error that can be exploited to dereference a null pointer. This can possibly allow the bypass of the safe mode protection by executing arbitrary code.
A remote attacker might be able to exploit this vulnerability in PHP applications making use of the sscanf() function, potentially resulting in the execution of arbitrary code or the execution of scripted contents in the context of the affected site.
There is no known workaround at this time.
All PHP 4.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.3-r1"
All PHP 5.x users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.4-r6"
August 29, 2006
March 29, 2008: 05