xine-lib: Buffer overflows — GLSA 200609-08

xine-lib is vulnerable to multiple buffer overflows that could be exploited to execute arbitrary code.

Affected Packages

media-libs/xine-lib on all architectures
Affected versions < 1.1.2-r2
Unaffected versions >= 1.1.2-r2

Background

xine is a high performance, portable and reusable multimedia playback engine. xine-lib is xine's core engine.

Description

xine-lib contains buffer overflows in the processing of AVI. Additionally, xine-lib is vulnerable to a buffer overflow in the HTTP plugin (xineplug_inp_http.so) via a long reply from an HTTP server.

Impact

An attacker could trigger the buffer overflow vulnerabilities by enticing a user to load a specially crafted AVI file in xine. This might result in the execution of arbitrary code with the rights of the user running xine. Additionally, a remote HTTP server serving a xine client a specially crafted reply could crash xine and possibly execute arbitrary code.

Workaround

There is no known workaround at this time.

Resolution

All xine-lib users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-libs/xine-lib-1.1.2-r2"

References

Release Date
September 13, 2006

Latest Revision
September 13, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries