Cheese Tracker: Buffer Overflow — GLSA 200610-13

Cheese Tracker contains a buffer overflow allowing the remote execution of arbitrary code.

Affected Packages

media-sound/cheesetracker on all architectures
Affected versions < 0.9.9-r1
Unaffected versions >= 0.9.9-r1

Background

Cheese Tracker is a Qt-based portable Impulse Tracker clone, a music tracker for the CT, IT, XM and S3M file formats.

Description

Luigi Auriemma reported that the XM loader of Cheese Tracker contains a buffer overflow vulnerability in the loader_XM::load_intrument_internal() function from loaders/loader_xm.cpp.

Impact

An attacker could execute arbitrary code with the rights of the user running Cheese Tracker by enticing a user to load a crafted file with large amount of extra data.

Workaround

There is no known workaround at this time.

Resolution

All Cheese Tracker users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-sound/cheesetracker-0.9.9-r1"

References

Release Date
October 26, 2006

Latest Revision
October 26, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries