PHP: Integer overflow — GLSA 200610-14

PHP is vulnerable to an integer overflow potentially allowing the remote execution of arbitrary code.

Affected Packages

dev-lang/php on all architectures
Affected versions < 5.1.6-r6
Unaffected versions revision >= 4.4.4-r6, revision >= 4.4.6, revision >= 4.4.7, revision >= 4.4.8_pre20070816, >= 5.1.6-r6

Background

PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.

Description

A flaw in the PHP memory handling routines allows an unserialize() call to be executed on non-allocated memory due to a previous integer overflow.

Impact

An attacker could execute arbitrary code with the rights of the web server user or the user running a vulnerable PHP script.

Workaround

There is no known workaround at this time.

Resolution

All PHP 5.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-5.1.6-r6"

All PHP 4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/php-4.4.4-r6"

References

Release Date
October 30, 2006

Latest Revision
March 29, 2008: 04

Severity
high

Exploitable
remote

Bugzilla entries