Qt: Integer overflow — GLSA 200611-02

An integer overflow flaw in the Qt pixmap handling could possibly lead to a Denial of Service or the remote execution of arbitrary code.

Affected Packages

x11-libs/qt on all architectures
Affected versions < 4.1.4-r2
Unaffected versions >= 4.1.4-r2, revision >= 3.3.6-r4, revision >= 3.3.8, revision >= 3.3.8b

Background

Qt is a cross-platform GUI toolkit, which is used e.g. by KDE.

Description

An integer overflow flaw has been found in the pixmap handling of Qt.

Impact

By enticing a user to open a specially crafted pixmap image in an application using Qt, e.g. Konqueror, a remote attacker could be able to cause an application crash or the execution of arbitrary code with the rights of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All Qt 3.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/qt-3.3.6-r4"

All Qt 4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=x11-libs/qt-4.1.4-r2"

References

Release Date
November 06, 2006

Latest Revision
January 09, 2009: 03

Severity
normal

Exploitable
remote

Bugzilla entries