wv library: Multiple integer overflows — GLSA 200612-01

The wv library is vulnerable to multiple integer overflows which could lead to the execution of arbitrary code.

Affected Packages

app-text/wv on all architectures
Affected versions < 1.2.3-r1
Unaffected versions >= 1.2.3-r1

Background

wv is a library for conversion of MS Word DOC and RTF files.

Description

The wv library fails to do proper arithmetic checks in multiple places, possibly leading to integer overflows.

Impact

An attacker could craft a malicious file that, when handled with the wv library, could lead to the execution of arbitrary code with the permissions of the user running the application.

Workaround

There is no known workaround at this time.

Resolution

All wv library users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-text/wv-1.2.3-r1"

References

Release Date
December 07, 2006

Latest Revision
December 07, 2006: 01

Severity
normal

Exploitable
remote

Bugzilla entries