SeaMonkey: Multiple vulnerabilities — GLSA 200612-08

Multiple vulnerabilities have been identified in the SeaMonkey project.

Affected Packages

www-client/seamonkey on all architectures
Affected versions < 1.0.6
Unaffected versions >= 1.0.6

Background

The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as 'Mozilla Application Suite'.

Description

The SeaMonkey project is vulnerable to arbitrary JavaScript bytecode execution and arbitrary code execution.

Impact

An attacker could entice a user to load malicious JavaScript or a malicious web page with a SeaMonkey application and execute arbitrary code with the rights of the user running those products. It is important to note that in the SeaMonkey email client, JavaScript is disabled by default.

Workaround

There is no known workaround at this time.

Resolution

All SeaMonkey users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.0.6"

References

Release Date
December 10, 2006

Latest Revision
December 10, 2006: 01

Severity
high

Exploitable
remote

Bugzilla entries