GNU Radius: Format string vulnerability — GLSA 200612-17

A format string vulnerabilty has been found in GNU Radius, which could lead to the remote execution of arbitrary code.

Affected Packages

net-dialup/gnuradius on all architectures
Affected versions < 1.4
Unaffected versions >= 1.4

Background

GNU Radius is a GNU version of Radius, a server for remote user authentication and accounting.

Description

A format string vulnerability was found in the sqllog function from the SQL accounting code for radiusd. That function is only used if one or more of the "postgresql", "mysql" or "odbc" USE flags are enabled, which is not the default, except for the "server" 2006.1 and 2007.0 profiles which enable the "mysql" USE flag.

Impact

An unauthenticated remote attacker could execute arbitrary code with the privileges of the user running radiusd, which may be the root user. It is important to note that there is no default GNU Radius user for Gentoo systems because no init script is provided with the package.

Workaround

There is no known workaround at this time.

Resolution

All GNU Radius users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-dialup/gnuradius-1.4"

References

Release Date
December 14, 2006

Latest Revision
December 14, 2006: 01

Severity
high

Exploitable
remote

Bugzilla entries