oftpd: Denial of Service — GLSA 200701-09

An assertion in oftpd could lead to a denial of service vulnerability.

Affected Packages

net-ftp/oftpd on all architectures
Affected versions < 0.3.7-r3
Unaffected versions >= 0.3.7-r3

Background

oftpd is a small, anonymous only ftp daemon.

Description

By specifying an unsupported address family in the arguments to a LPRT or LPASV command, an assertion in oftpd will cause the daemon to abort.

Impact

Remote, unauthenticated attackers may be able to terminate any oftpd process, denying service to legitimate users.

Workaround

There is no known workaround at this time.

Resolution

All oftpd users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-ftp/oftpd-0.3.7-r3"

References

Release Date
January 15, 2007

Latest Revision
January 15, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries