Asterisk: SIP Denial of Service — GLSA 200703-14

Asterisk is vulnerable to Denial of Service in the SIP channel.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 1.2.14-r1
Unaffected versions >= 1.2.14-r1, revision >= 1.0.12-r1

Background

Asterisk is an open source implementation of a telephone private branch exchange (PBX).

Description

The MU Security Research Team discovered that Asterisk contains a NULL-pointer dereferencing error in the SIP channel when handling request messages.

Impact

A remote attacker could cause an Asterisk server listening for SIP messages to crash by sending a specially crafted SIP request message.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose net-misc/asterisk

Note: Asterisk 1.0.x is no longer supported upstream so users should consider upgrading to Asterisk 1.2.x.

References

Release Date
March 16, 2007

Latest Revision
March 16, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries