PostgreSQL: Multiple vulnerabilities — GLSA 200703-15

PostgreSQL contains two vulnerabilities that could result in a Denial of Service or unauthorized access to certain information.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 8.0.11
Unaffected versions >= 8.0.11, revision >= 7.4.17, revision >= 7.4.16, revision >= 7.3.19, revision >= 7.3.13, revision >= 7.3.21, revision >= 7.4.19

Background

PostgreSQL is an open source object-relational database management system.

Description

PostgreSQL does not correctly check the data types of the SQL function arguments under unspecified circumstances nor the format of the provided tables in the query planner.

Impact

A remote authenticated attacker could send specially crafted queries to the server that could result in a server crash and possibly the unauthorized reading of some database content or arbitrary memory.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose "dev-db/postgresql"

References

Release Date
March 16, 2007

Latest Revision
May 28, 2009: 04

Severity
normal

Exploitable
remote

Bugzilla entries