Asterisk: Two SIP Denial of Service vulnerabilities — GLSA 200704-01

Asterisk is vulnerable to two Denial of Service issues in the SIP channel.

Affected Packages

net-misc/asterisk on all architectures
Affected versions < 1.2.14-r2
Unaffected versions >= 1.2.14-r2, revision >= 1.0.12-r2

Background

Asterisk is an open source implementation of a telephone private branch exchange (PBX).

Description

The Madynes research team at INRIA has discovered that Asterisk contains a null pointer dereferencing error in the SIP channel when handling INVITE messages. Furthermore qwerty1979 discovered that Asterisk 1.2.x fails to properly handle SIP responses with return code 0.

Impact

A remote attacker could cause an Asterisk server listening for SIP messages to crash by sending a specially crafted SIP message or answering with a 0 return code.

Workaround

There is no known workaround at this time.

Resolution

All Asterisk users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose net-misc/asterisk

Note: Asterisk 1.0.x is no longer supported upstream so users should consider upgrading to Asterisk 1.2.x.

References

Release Date
April 02, 2007

Latest Revision
April 02, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries