PostgreSQL: Privilege escalation — GLSA 200705-12

PostgreSQL contains a vulnerability that could result in SQL privilege escalation.

Affected Packages

dev-db/postgresql on all architectures
Affected versions < 8.0.13
Unaffected versions >= 8.0.13, revision >= 7.4.17, revision >= 7.3.19, revision >= 7.3.21, revision >= 7.4.19

Background

PostgreSQL is an open source object-relational database management system.

Description

An error involving insecure search_path settings in the SECURITY DEFINER functions has been reported in PostgreSQL.

Impact

If allowed to call a SECURITY DEFINER function, an attacker could gain the SQL privileges of the owner of the called function.

Workaround

There is no known workaround at this time.

Resolution

All PostgreSQL users should upgrade to the latest version and fix their SECURITY DEFINER functions:

 # emerge --sync
 # emerge --ask --oneshot --verbose "dev-db/postgresql"

In order to fix the SECURITY DEFINER functions, PostgreSQL users are advised to refer to the PostgreSQL documentation: http://www.postgresql .org/docs/techdocs.77

References

Release Date
May 10, 2007

Latest Revision
May 28, 2009: 02

Severity
normal

Exploitable
remote

Bugzilla entries