Sun JDK/JRE: Multiple vulnerabilities — GLSA 200705-23

Multiple vulnerabilities have been identified in Sun Java Development Kit (JDK) and Java Runtime Environment (JRE).

Affected Packages

dev-java/sun-jdk on all architectures
Affected versions < 1.5.0.11
Unaffected versions >= 1.5.0.11, revision >= 1.4.2.14, revision >= 1.4.2.15, revision >= 1.4.2.19
dev-java/sun-jre-bin on all architectures
Affected versions < 1.6.0.01
Unaffected versions >= 1.6.0.01, revision >= 1.5.0.16, revision >= 1.5.0.15, revision >= 1.5.0.12, revision >= 1.5.0.11, revision >= 1.4.2.18, revision >= 1.4.2.17, revision >= 1.4.2.15, revision >= 1.4.2.14, revision >= 1.4.2.19, revision >= 1.5.0.17, revision >= 1.5.0.18

Background

The Sun Java Development Kit (JDK) and the Sun Java Runtime Environment (JRE) provide the Sun Java platform.

Description

An unspecified vulnerability involving an "incorrect use of system classes" was reported by the Fujitsu security team. Additionally, Chris Evans from the Google Security Team reported an integer overflow resulting in a buffer overflow in the ICC parser used with JPG or BMP files, and an incorrect open() call to /dev/tty when processing certain BMP files.

Impact

A remote attacker could entice a user to run a specially crafted Java class or applet that will trigger one of the vulnerabilities. This could lead to the execution of arbitrary code outside of the Java sandbox and of the Java security restrictions, or crash the Java application or the browser.

Workaround

There is no known workaround at this time.

Resolution

All Sun Java Development Kit users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose "dev-java/sun-jdk"

All Sun Java Runtime Environment users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose "dev-java/sun-jre-bin"

References

Release Date
May 31, 2007

Latest Revision
May 28, 2009: 05

Severity
normal

Exploitable
remote

Bugzilla entries