MadWifi: Multiple vulnerabilities — GLSA 200706-04

Multiple vulnerabilities have been discovered in MadWifi, possibly allowing for the execution of arbitrary code or a Denial of Service.

Affected Packages

net-wireless/madwifi-ng on all architectures
Affected versions < 0.9.3.1
Unaffected versions >= 0.9.3.1

Background

The MadWifi driver provides support for Atheros based IEEE 802.11 Wireless Lan cards.

Description

Md Sohail Ahmad from AirTight Networks has discovered a divison by zero in the ath_beacon_config() function (CVE-2007-2830). The vendor has corrected an input validation error in the ieee80211_ioctl_getwmmparams() and ieee80211_ioctl_getwmmparams() functions(CVE-207-2831), and an input sanitization error when parsing nested 802.3 Ethernet frame lengths (CVE-2007-2829).

Impact

An attacker could send specially crafted packets to a vulnerable host to exploit one of these vulnerabilities, possibly resulting in the execution of arbitrary code with root privileges, or a Denial of Service.

Workaround

There is no known workaround at this time.

Resolution

All MadWifi users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-wireless/madwifi-ng-0.9.3.1"

References

Release Date
June 11, 2007

Latest Revision
June 11, 2007: 01

Severity
high

Exploitable
remote

Bugzilla entries