emul-linux-x86-java: Multiple vulnerabilities — GLSA 200706-08

Multiple vulnerabilities have been discovered in emul-linux-x86-java, possibly resulting in the execution of arbitrary code or a Denial of Service.

Affected Packages

app-emulation/emul-linux-x86-java on all architectures
Affected versions < 1.5.0.11
Unaffected versions >= 1.5.0.11, revision >= 1.4.2.16, revision >= 1.4.2.17, revision >= 1.4.2.19

Background

emul-linux-x86-java is the 32 bit version of the Sun's J2SE Development Kit.

Description

Chris Evans of the Google Security Team has discovered an integer overflow in the ICC parser, and another vulnerability in the BMP parser. An unspecified vulnerability involving an "incorrect use of system classes" was reported by the Fujitsu security team.

Impact

A remote attacker could entice a user to open a specially crafted image, possibly resulting in the execution of arbitrary code with the privileges of the user running Emul-linux-x86-java. They also could entice a user to open a specially crafted BMP image, resulting in a Denial of Service. Note that these vulnerabilities may also be triggered by a tool processing image files automatically.

Workaround

There is no known workaround at this time.

Resolution

All Emul-linux-x86-java users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=app-emulation/emul-linux-x86-java-1.5.0.11"

References

Release Date
June 26, 2007

Latest Revision
May 28, 2009: 03

Severity
normal

Exploitable
remote

Bugzilla entries