Mozilla products: Multiple vulnerabilities — GLSA 200708-09

Multiple vulnerabilities have been reported in Mozilla Firefox, Thunderbird, SeaMonkey and XULRunner, some of which may allow user-assisted arbitrary remote code execution.

Affected Packages

www-client/mozilla-firefox on all architectures
Affected versions < 2.0.0.6
Unaffected versions >= 2.0.0.6
www-client/mozilla-firefox-bin on all architectures
Affected versions < 2.0.0.6
Unaffected versions >= 2.0.0.6
mail-client/mozilla-thunderbird on all architectures
Affected versions < 2.0.0.6
Unaffected versions >= 2.0.0.6
mail-client/mozilla-thunderbird-bin on all architectures
Affected versions < 2.0.0.6
Unaffected versions >= 2.0.0.6
www-client/seamonkey on all architectures
Affected versions < 1.1.4
Unaffected versions >= 1.1.4
www-client/seamonkey-bin on all architectures
Affected versions < 1.1.4
Unaffected versions >= 1.1.4
net-libs/xulrunner on all architectures
Affected versions < 1.8.1.6
Unaffected versions >= 1.8.1.6

Background

Mozilla Firefox is an open-source web browser from the Mozilla Project, and Mozilla Thunderbird an email client. The SeaMonkey project is a community effort to deliver production-quality releases of code derived from the application formerly known as the 'Mozilla Application Suite'. XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM applications like Firefox and Thunderbird.

Description

Mozilla developers fixed several bugs, including an issue with modifying XPCNativeWrappers (CVE-2007-3738), a problem with event handlers executing elements outside of the document (CVE-2007-3737), and a cross-site scripting (XSS) vulnerability (CVE-2007-3736). They also fixed a problem with promiscuous IFRAME access (CVE-2007-3089) and an XULRunner URL spoofing issue with the wyciwyg:// URI and HTTP 302 redirects (CVE-2007-3656). Denials of Service involving corrupted memory were fixed in the browser engine (CVE-2007-3734) and the JavaScript engine (CVE-2007-3735). Finally, another XSS vulnerability caused by a regression in the CVE-2007-3089 patch was fixed (CVE-2007-3844).

Impact

A remote attacker could entice a user to view a specially crafted web page that will trigger one of the vulnerabilities, possibly leading to the execution of arbitrary code or a Denial of Service. It is also possible for an attacker to perform cross-site scripting attacks, which could result in the exposure of sensitive information such as login credentials.

Workaround

There is no known workaround at this time.

Resolution

All Mozilla Firefox users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-2.0.0.6"

All Mozilla Firefox binary users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-bin-2.0.0.6"

All Mozilla Thunderbird users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-2.0.0.6"

All Mozilla Thunderbird binary users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=mail-client/mozilla-thunderbird-bin-2.0.0.6"

All SeaMonkey users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/seamonkey-1.1.4"

All SeaMonkey binary users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=www-client/seamonkey-bin-1.1.4"

All XULRunner users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-libs/xulrunner-1.8.1.6"

References

Release Date
August 14, 2007

Latest Revision
August 14, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries