Streamripper: Buffer overflow — GLSA 200709-03

A buffer overflow vulnerability has been discovered in Streamripper, allowing for user-assisted execution of arbitrary code.

Affected Packages

media-sound/streamripper on all architectures
Affected versions < 1.62.2
Unaffected versions >= 1.62.2

Background

Streamripper is a tool for extracting and recording mp3 files from a Shoutcast stream.

Description

Chris Rohlf discovered several boundary errors in the httplib_parse_sc_header() function when processing HTTP headers.

Impact

A remote attacker could entice a user to connect to a malicious streaming server, resulting in the execution of arbitrary code with the privileges of the user running Streamripper.

Workaround

There is no known workaround at this time.

Resolution

All Streamripper users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=media-sound/streamripper-1.62.2"

References

Release Date
September 13, 2007

Latest Revision
September 13, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries