NX 2.1: User-assisted execution of arbitrary code — GLSA 200710-09

NX in the 2.1 series uses XFree86 4.3 code which is prone to an integer overflow vulnerability.

Affected Packages

net-misc/nx on all architectures
Affected versions < 3.0.0
Unaffected versions >= 3.0.0
net-misc/nxnode on all architectures
Affected versions < 3.0.0-r3
Unaffected versions >= 3.0.0-r3

Background

NoMachine's NX establishes remote connections to X11 desktops over small bandwidth links. NX and NX Node are the compression core libraries, whereas NX is used by FreeNX and NX Node by the binary-only NX servers.

Description

Chris Evans reported an integer overflow within the FreeType PCF font file parser (CVE-2006-1861). NX and NX Node are vulnerable to this due to shipping XFree86 4.3.0, which includes the vulnerable FreeType code.

Impact

A remote attacker could exploit these integer overflows by enticing a user to load a specially crafted PCF font file which might lead to the execution of arbitrary code with the privileges of the user on the machine running the NX server.

Workaround

There is no known workaround at this time.

Resolution

All NX users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/nx-3.0.0"

All NX Node users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-misc/nxnode-3.0.0-r3"

References

Release Date
October 09, 2007

Latest Revision
October 09, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries