Python: User-assisted execution of arbitrary code — GLSA 200711-07

Multiple integer overflow vulnerabilities have been discovered in Python, possibly resulting in the execution of arbitrary code or a Denial of Service.

Affected Packages

dev-lang/python on all architectures
Affected versions < 2.4.4-r6
Unaffected versions revision >= 2.3.6-r3, >= 2.4.4-r6

Background

Python is an interpreted, interactive, object-oriented programming language.

Description

Slythers Bro discovered multiple integer overflows in the imageop module, one of them in the tovideo() method, in various locations in files imageop.c, rbgimgmodule.c, and also in other files.

Impact

A remote attacker could entice a user to process specially crafted images with an application using the Python imageop module, resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service. Note that this vulnerability may or may not be exploitable, depending on the application using the module.

Workaround

There is no known workaround at this time.

Resolution

All Python 2.3.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.3.6-r3"

All Python 2.4.x users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r6"

References

Release Date
November 07, 2007

Latest Revision
November 07, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries