Net-SNMP: Denial of Service — GLSA 200711-31

A Denial of Service vulnerability has been discovered in Net-SNMP when processing GETBULK requests.

Affected Packages

net-analyzer/net-snmp on all architectures
Affected versions < 5.4.1-r1
Unaffected versions >= 5.4.1-r1

Background

Net-SNMP is a collection of tools for generating and retrieving SNMP data.

Description

The SNMP agent (snmpd) does not properly handle GETBULK requests with an overly large "max-repetitions" field.

Impact

A remote unauthenticated attacker could send a specially crafted SNMP request to the vulnerable application, possibly resulting in a high CPU and memory consumption.

Workaround

There is no known workaround at this time.

Resolution

All Net-SNMP users should upgrade to the latest version:

 # emerge --sync
 # emerge --ask --oneshot --verbose ">=net-analyzer/net-snmp-5.4.1-r1"

References

Release Date
November 20, 2007

Latest Revision
November 20, 2007: 01

Severity
normal

Exploitable
remote

Bugzilla entries